martedì 23 luglio 2013

TS5 QOS on frame-relay


R25#

class-map match-all voice
 match ip precedence 6
!
policy-map frts
 class class-default
    shape average 8000
    shape adaptive 8000
policy-map voice
 class voice
    priority percent 80

map-class frame-relay frts
 frame-relay cir 1000
 frame-relay bc 8000
 service-policy output frts    <-- applica la policy-map frts
!
map-class frame-relay voice





interface Serial0/0
 no ip address
 encapsulation frame-relay
 load-interval 30
 serial restart-delay 0
 frame-relay class frts    <-- è applicata  la class-map frts all'interfaccia fisica
 no frame-relay inverse-arp
!        
interface Serial0/0.345 multipoint
 ip address 10.10.10.3 255.255.255.248
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 ip ospf priority 100
 snmp trap link-status
 frame-relay map ip 10.10.10.2 254 broadcast
 frame-relay map ip 10.10.10.1 253 broadcast
 frame-relay interface-dlci 253
  class frts                  <-- la class-map frts deve essere applicata al DLCI 253
 no frame-relay inverse-arp

R25#sh policy-map interface Serial0/0.345 | b DLCI 253
 Serial0/0.345: DLCI 253 -
  Service-policy output: frts
    Class-map: class-default (match-any)
      1290 packets, 119925 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 1290/119925
      shape (average) cir 8000, bc 32, be 32     <----- shape average deve essere 500000
      target shape rate 8000
        lower bound cir 8000,  adapt to fecn 0

R25(config)#policy-map frts
R25(config-pmap)#class class-default
R25(config-pmap-c)#shape average 500000

R25#sh policy-map interface Serial0/0.345
 Serial0/0.345: DLCI 253 -
  Service-policy output: frts
    Class-map: class-default (match-any)
      51 packets, 4188 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 51/4188
      shape (average) cir 500000, bc 2000, be 2000 <-- adesso è corretto
      target shape rate 500000
        lower bound cir 8000,  adapt to fecn 0



     


nota: la riga "frame-relay interface-dlci 253" è necessaria per applicare la CLASS_MAP 

R25
interface Serial0/0.345 multipoint
 ip address 10.10.10.3 255.255.255.248
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 ip ospf priority 100
 snmp trap link-status
 frame-relay map ip 10.10.10.2 254 broadcast
 frame-relay map ip 10.10.10.1 253 broadcast
 frame-relay interface-dlci 253  <--------- è necessario per applicare la CLASS_MAP
  class frts
 no frame-relay inverse-arp



l'applicazione della CLASS_MAP richiede di definire l'interface-dlci 253 provando ad applicarla alla subinterface otteniamo un errore
       


il comando "sh policy-map interface"  deve matchare l'output  fornito, notiamo subito che la policy-map "voice è assente questo è dovuto alla POLICY-MAP "frts" che non richiama la POLICY-MAP "voice"



R25#sh policy-map interface Serial0/0.345 | b DLCI 253
Serial0/0.345: DLCI 253 -
  Service-policy output: frts
    Class-map: class-default (match-any)
      179 packets, 14178 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 179/14178
      shape (average) cir 500000, bc 2000, be 2000
      target shape rate 500000
        lower bound cir 8000,  adapt to fecn 0



la policy-map frts non richiama la policy-map voice

policy-map frts
class class-default
shape average 8000
shape adaptive 8000    <---- DEVE ESSERE ANNIDATA LA POLICY-MAP VOICE
policy-map voice
class voice
priority percent 80

i seguenti comandi permettono di richiamare la policy-map voice dentro la policy-map frts

R25(config)#policy-map frts
R25(config-pmap)#class class-default
R25(config-pmap-c)#service-policy voice



LA MAP-CLASS "FRTS"  DEVE RICHIAMARE LA POLICY-MAP "FRTS"

map-class frame-relay frts
frame-relay cir 1000
frame-relay bc 8000
service-policy output frts <--  RICHIAMA LA POLICY-MAP
!

i seguenti comandi applicano la policy-map "frts"all'interno della class map "frts"

R25(config)#map-class frame-relay frts
R25(config-map-class)#service-policy output frts    




RICAPITOLANDO:

1) La POLICY-MAP voice deve essere annidata all'interno della POLICY-MAP frts

policy-map frts
 class class-default
    shape average 500000
    shape adaptive 8000
  service-policy voice   <------ si richiama (annida)  la POLICY-MAP voice

2) la CLASS-MAP frts  richiama la POLICY-MAP frts

map-class frame-relay frts
 frame-relay cir 1000
 frame-relay bc 8000
 service-policy output frts  <------ si applica la POLICY-MAP

3) la CLASS-MAP frts è applicata al DLCI 253 (deve essere configurata anche sotto l'interface fisica)

interface Serial0/0
 no ip address
 encapsulation frame-relay
 load-interval 30
 serial restart-delay 0
 frame-relay class frts   <-------- si applica  la CLASS-MAP
 no frame-relay inverse-arp
!
interface Serial0/0.345 multipoint
 ip address 10.10.10.3 255.255.255.248
 ip pim sparse-mode
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint
 ip ospf priority 100
 snmp trap link-status
 frame-relay map ip 10.10.10.2 254 broadcast
 frame-relay map ip 10.10.10.1 253 broadcast
 frame-relay interface-dlci 253
  class frts            <--------  si applica la CLASS-MAP
 no frame-relay inverse-arp


4) sotto l'interfaccia fisica si deve fare traffic shaping

R25#sh policy-map interface Serial0/0.345 | b DLCI 253
 Serial0/0.345: DLCI 253 -
  Service-policy output: frts
    Class-map: class-default (match-any)
      253 packets, 20024 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 253/20024
      shape (average) cir 500000, bc 2000, be 2000
      target shape rate 500000
        lower bound cir 8000,  adapt to fecn 0
      Service-policy : voice
        queue stats for all priority classes:
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 253/20024
         
        Class-map: voice (match-all)
          253 packets, 20024 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 6
          Priority: 80% (400 kbps), burst bytes 10000, b/w exceed drops: 0
         
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any
         
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0












The following example shows how to apply a map class to a DLCI for which a frame-relay map statement exists. The frame-relay interface-dlci command must also be used.

interface serial 0.2 point-to-multipoint

 frame-relay map ip 131.26.13.2 100

 frame-relay interface-dlci 100

  class slow_vcs

interface serial 0

 frame-relay interface-dlci 100

  class fast_vc

map-class frame-relay fast_vc

 frame-relay traffic-rate 56000 128000

 frame-relay idle-timer 30

This is the most well-known FRTS method, which has been available for quite a while on Cisco routers. It is now being outdated by MQC configurations.
The key characteristic is that all settings are configured under map-class command mode, and later are applied to a particular set PVCs. The
same configuration concept was used for legacy ATM configuration mode (map-class atm).

Legacy FRTS has the following characteristics:



- Enabled with frame-relay traffic-shaping command at physical interface level
- Incompatible with GTS or MQC commands at subinterfaces or physical interface levels
- With FRTS you can enforce bitrate per-VC (VC-granular, unlike GTS), by applying a map-class to PVC
- When no map-class is explicitly applied to PVC, it’s CIR and Tc are set to 56K/125ms by default
- Shaping parameters are configured under map-class frame-relay configuration submode
- Allows to configure fancy-queueing (WFQ/PQ/CQ) or simple FIFO per-VC
- No option to configure fancy-queueing at interface level: interface queue is forced to FIFO (if no FRF.12 is configured)
- Allows for adaptive shaping (throttling down to minCIR) on BECN reception (just as GTS) and option to reflect incoming FECNs as BECNs
- Option to enable adaptive shaping which responds to interface congestion (non-empty interface queue)





Example: Shape PVC to 384Kbps with minimal Tc (10ms) and WFQ as interface queue

 

map-class frame-relay SHAPE_384K
 frame-relay cir 384000
 frame-relay bc 3840
 frame-relay be 0
 !
 ! Adaptive shaping: respond to BECNs and interface congestion
 !
 frame-relay adaptive-shaping becn
 frame-relay adaptive-shaping interface-congestion
 !
 ! Per-VC fancy-queueing
 !
 frame-relay fair-queue
!
interface Serial 0/0/0:0
 frame-relay traffic-shaping
!
interface Serial 0/0/0:0.1
 ip address 177.0.112.1 255.255.255.0
 frame-relay interface-dlci 112
  class SHAPE_384K






giovedì 11 luglio 2013

IPv6 OSPF V3

OSPF v3

A: OSPFv3 uses link-local IPv6 addresses for neighbor discovery and establishment
Unlike IPv4 OSPF, OSPFv3 uses link-local IPv6 addresses for neighbor discovery. Some of the key fidifferences between
The key differences between the OSPFv3 and OSPFv2 protocols include:
• OSPFv3 expands on OSPFv2 to provide support for IPv6 routing prefixes and the larger size of IPv6 addresses.
• LSAs in OSPFv3 are expressed as prefix and prefix length instead of address and mask.
• The router ID and area ID are 32-bit numbers with no relationship to IPv6 addresses.
OSPFv3 uses link-local IPv6 addresses for neighbor discovery and other features.
• OSPFv3 uses IPv6 for authentication.
• OSPFv3 redefines LSA types.

LICENSE 3750