Objective
This tech note outlines the main differences in Layer 3 virtualization support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.
Virtualization Routing and Forwarding Overview
Virtual Routing and Forwarding (VRF) provides an additional layer of network virtualization on top of virtual device contexts (VDCs). VRF provides separate unicast and multicast address space and associated routing protocols that make independent forwarding decisions. All unicast and multicast protocols support VRF functionality.
Important Cisco NX-OS and Cisco IOS Software Differences
In Cisco NX-OS:
Cisco NX-OS supports 1000 VRF instances per chassis consisting of 250 VRF instances per VDC with 4 VDCs (994 VRF instances can be configured in 1 VDC).
Two VRF instances are configured by default. The management port on the supervisor module is assigned to the management VRF, and all I/O module ports are assigned to the default VRF.
VRF instances can be enabled without any command-line interface (CLI) prerequisites. Cisco IOS Software requires ip cef to be enabled globally before a VRF instance can be configured.
Multicast routing/forwarding can be configured per VRF instance without having to globally enable the VRF instance for multicast . Cisco IOS Software requires the global ip multicast-routing vrf <name> command per VRF instance.
The CLI for enabling VRF routing for a protocol is consistent for all routing protocols, whereas Cisco IOS Software uses address families for Border Gateway Protocol (BGP), Routing Information Protocol (RIP), and Enhanced Interior Gateway Routing Protocol (EIGRP) and requires unique routing process IDs per VRF for Integrated Intermediate System-to-Intermediate System (ISIS) and Open Shortest Path First (OSPF).
In Cisco NX-OS, numerous VRF instances can be assigned to a single routing protocol instance.
IP static routes are configured under the specified vrf context. In Cisco IOS Software, all static routes are configured in global configuration mode with the vrf option.
A VRF instance can be manually disabled with the shutdown command. Cisco IOS Software does not have the CLI capability to manually disable a VRF instance.
If a VRF context is removed with the no vrf context <name> configuration command, the VRF context commands will be removed from the running configuration making the VRF non-functional, but all non context related VRF commands will remain in the running configuration. When a VRF is removed in Cisco IOS Software, the VRF instance and all related VRF commands are automatically removed from the running configuration, including any interface IP addresses previously associated to the VRF instance.
The default VRF instance is the default routing context for all show commands.
Things You Should Know
The following list provides some additional facts about Cisco NX-OS that should be helpful when configuring and maintaining VRF instances.
When you assign a VRF instance to an interface with an IP address previously configured, the interface IP address is automatically removed.
Static routes or dynamic routing protocols can be configured for routing in a VRF instance (BGP, EIGRP, ISIS, OSPF, static routes, and RIPv2).
IP troubleshooting tools such as ping and traceroute are VRF aware and require the name of a specific VRF instance if testing in the default VRF instance is not desired.
The routing-context vrf command can be executed in EXEC mode to change the routing context to a non-default VRF instance. For example, typing routing-context vrf management changes the routing context, so all VRF related commands are executed in the management VRF as opposed to the default VRF.
Network management–related services such as authentication, authorization and accounting (AAA), Call Home, DNS, FTP, HTTP, NetFlow, NTP, PING, RADIUS, SCP, sFTP, SNMP, SSH, Syslog, TACACS+, TELNET, TFTP, Traceroute, and XML are VRF aware.
The global configuration write erase boot command will erase the management VRF instance configuration. The write erase command without the boot option will not.
Configuration Comparison
The following sample code shows configuration similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. Sample code is provided only to illustrate how to enable VRF routing. The Cisco NX-OS CLI is simpler and more consistent since it allows multiple VRF instances to be assigned to a single routing protocol instance, whereas Cisco IOS Software uses different techniques depending on the routing protocol.
Cisco IOS CLI | Cisco NX-OS CLI |
Creating a VRF Instance |
ip cef ip vrf vrf-1 New Syntax: vrf definition vrf-1 address-family ipv4 | vrf context vrf-1 |
Assigning an Interface to a VRF |
interface Ethernet2/1 ip vrf forwarding vrf-1 ip address 192.168.10.1 255.255.255.0 | interface Ethernet2/1 vrf member vrf-1 ip address 192.168.10.1/24 |
Enabling BGP in a VRF |
router bgp 10 address-family ipv4 vrf vrf-1 neighbor 192.168.10.2 remote-as 20 neighbor 192.168.10.2 activate network 192.168.1.1 mask 255.255.255.255 exit-address-family | router bgp 10 vrf vrf-1 address-family ipv4 unicast network 192.168.1.1/32 neighbor 192.168.10.2 remote-as 20 address-family ipv4 unicast |
Enabling EIGRP in a VRF |
interface Ethernet2/1 ip vrf forwarding vrf-1 ip address 192.168.10.1 255.255.255.0 router eigrp 10 address-family ipv4 vrf vrf-1 autonomous-system 10 network 192.168.10.0 no auto-summary | interface Ethernet2/1 vrf member vrf-1 ip address 192.168.10.1/24 ip router eigrp 10 router eigrp 10 vrf vrf-1 |
Enabling ISIS in a VRF |
interface Ethernet2/1 ip vrf forwarding vrf-1 ip address 192.168.10.1 255.255.255.0 ip router isis 10 router isis 10 vrf vrf-1 net 49.0001.0000.0001.00 | interface Ethernet2/1 vrf member vrf-1 ip address 192.168.10.1/24 ip router isis 10 router isis 10 vrf vrf-1 net 49.0001.0000.0001.00 |
Enabling OSPF in a VRF |
interface Ethernet2/1 ip vrf forwarding vrf-1 ip address 192.168.10.1 255.255.255.0 router ospf 10 vrf vrf-1 network 192.168.10.0 0.0.0.255 area 0 | interface Ethernet2/1 vrf member vrf-1 ip address 192.168.10.1/24 ip router ospf 10 area 0 router ospf 10 vrf vrf-1 |
Enabling RIPv2 in a VRF |
interface Ethernet2/1 ip vrf forwarding vrf-1 ip address 192.168.10.1 255.255.255.0 router rip address-family ipv4 vrf vrf-1 network 192.168.10.0 version 2 exit-address-family | interface Ethernet2/1 vrf member vrf-1 ip address 192.168.10.1/24 ip router rip 10 router rip 10 vrf vrf-1 |
Configuring Static Routes in a VRF |
ip route vrf vrf-1 192.168.2.0 255.255.255.0 192.168.10.2 | vrf context vrf-1 ip route 192.168.2.0/24 192.168.10.2 |
Verification Command Comparison
The following table compares some useful show commands for verifying and troubleshooting VRF instances.
Cisco NX-OS VRF | Cisco IOS Software VRF | Command Description |
show vrf | show ip vrf | Displays a list of all configured VRF instances |
show vrf <name> | show ip vrf <name> | Displays a specific VRF instance |
show vrf <name> detail | show ip vrf detail <name> | Displays details for a specific VRF instance |
show vrf <name> interface | - | Displays the interface assignment for a specific VRF instance |
show vrf default | - | Displays a summary of the default VRF instance |
show vrf detail | show ip vrf detail | Displays details for all VRF instances |
show vrf interface | show ip vrf interfaces | Displays VRF interface assignments for all VRF instances |
show vrf management | - | Displays a summary of the management VRF instance |
- | - | - |
show ip route vrf all | - | Displays routes for all VRF instances |
show ip route vrf default | - | Displays routes for the default VRF instance |
show ip route vrf management | - | Displays routes for the management VRF instance |
show ip route vrf <name> | show ip route vrf <name> | Displays routes for a specific VRF instance (multiple sub-options) |
- | - | - |
show ip arp vrf <name> | show ip arp vrf <name> | Displays Address Resolution Protocol (ARP) entries for a specific VRF instance |
- | - | - |
show ip bgp vrf <name> | show ip bgp vpnv4 vrf <name> | Displays BGP commands for a specific VRF instance |
show ip eigrp vrf <name> | show ip eigrp vrf <name> | Displays EIGRP information for specific VRF instance |
show ip isis vrf <name> | show isis <#> | Displays ISIS commands for a specific VRF instance |
show ip ospf vrf <name> | show ip ospf <#> | Displays OSPF information for a specific VRF instance |
show ip rip vrf <name> | show ip rip database vrf <name> | Displays RIP information for a specific VRF instance |
show ip static-route vrf <name> | - | Displays static routes for a specific VRF instance |
- | - | - |
show forwarding vrf <name> | show ip cef vrf <name> | Displays FIB information for a specific VRF (multiple sub-options) |
- | - | - |
show routing vrf | - | Displays a subset of the show vrf commands |
show routing-context | - | Displays the current routing context |
Cisco NX-OS/IOS HSRP Comparison
Objective
This tech note outlines the main differences in Hot Standby Routing Protocol (HSRP) (IPv4) support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.
HSRP Overview
HSRP is a Cisco proprietary First Hop Redundancy Protocol (FHRP) designed to allow transparent failover for an IP client’s default gateway (first-hop router).
Important Cisco NX-OS and Cisco IOS Software Differences
In Cisco NX-OS:
HSRP command-line interface (CLI) configuration and verification commands are not available until you enable the HSRP feature with the feature hsrp command.
HSRP is hierarchical. All related commands for an HSRP group are configured under the group number.
The HSRP configuration commands use the format hsrp <option> instead of standby <option>.
The HSRP verification commands use the format show hsrp <option> instead of show standby <option>.
HSRP supports stateful process restarts, and switchovers if two supervisor modules are present.
The hello and hold-time timer ranges for the millisecond options are different. In Cisco NX-OS, hello = 250 to 999 milliseconds, and hold time = 750 to 3000 milliseconds. In Cisco IOS Software, hello = 15 to 999 milliseconds, and hold time = 50 to 3000 milliseconds.
HSRP supports Bidirectional Forwarding Detection (BFD). Cisco IOS Software does not support BFD for HSRP.
Things You Should Know
The following list provides some additional facts about Cisco NX-OS that should be helpful when designing, configuring, and maintaining HSRP-enabled networks.
If you remove the feature hsrp command, all relevant HSRP configuration information is also removed.
HSRPv1 is enabled by default (HSRPv2 can be enabled per interface).
HSRPv1 supports 256 group numbers (0 to 255). HSRPv2 supports 4096 group numbers (0 to 4095).
HSRPv1 and HSRPv2 are not compatible. However, a device can be configured to run a different version on different interfaces.
The show running-config hsrp command displays the current HSRP configuration.
Configuration of more than one FHRP on an interface is not recommended.
Object tracking is supported. Tracking can be configured for an interface’s line protocol state, IP address state, and for IP route reachability (determining whether a route is available in the routing table).
An interface can track multiple objects.
Secondary IP addresses are supported in the same or a different group as the interface’s primary IP address.
Load sharing can be accomplished by using multiple HSRP groups per interface
HSRP has been enhanced for vPC environments, so both the active and standby router can forward data traffic. The primary router (higher priority) responds to ARP requests.
Extended hold timers can be configured globally (hsrp timers extended-hold) to temporarily extend timeout values during an In Service Software Upgrade (ISSU). This prevents unnecessary HSRP switch-overs in environments that use aggressive hello/hold timers.
Configuration Comparison
The following sample code shows configuration similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. There are two significant differences: Cisco NX-OS uses a hierarchical configuration, and it uses the hsrp keyword instead of the standby keyword for configuration and verification commands. The enhancements make the configuration easier to read and work with.
Cisco IOS CLI | Cisco NX-OS CLI |
Enabling the HSRP Feature |
Cisco IOS Software does not have the ability to enable or disable HSRP. | feature hsrp |
Configuring HSRP on an Interface |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby 0 ip 192.168.10.1 | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp 0 ip 192.168.10.1 |
Configuring the priority and preempt Options |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby 0 ip 192.168.10.1 standby 0 priority 110 standby 0 preempt | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp 0 preempt priority 110 ip 192.168.10.1 |
Modifying the Hello and Holdtime Timers (Seconds) |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby 0 ip 192.168.10.1 standby 0 timers 1 3 | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp 0 timers 1 3 ip 192.168.10.1 |
Modifying the Hello and Holdtime Timers (Milliseconds) |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby 0 ip 192.168.10.1 standby 0 timers msec 250 msec 750 | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp 0 timers msec 250 msec 750 ip 192.168.10.1 |
Configuring MD5 Authentication |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby 0 ip 192.168.10.1 standby 0 authentication md5 key-string cisco123 | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp 0 authentication md5 key-string cisco123 ip 192.168.10.1 |
Configuring HSRP Version 2 on an Interface |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby version 2 | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp version 2 |
Configuring Minimum and Reload Initialization Delay |
interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby delay minimum 5 reload 10 | interface Ethernet2/1 ip address 192.168.10.2/24 hsrp delay minimum 5 reload 10 |
Configuring Object Tracking (Interface Line-Protocol) |
track 1 interface Ethernet2/2 line-protocol interface Ethernet2/1 ip address 192.168.10.2 255.255.255.0 standby 0 ip 192.168.10.1 standby 0 track 1 decrement 20 | track 1 interface ethernet 2/2 line-protocol interface Ethernet2/1 ip address 192.168.10.2/24 hsrp 0 track 1 decrement 20 ip 192.168.10.1 |
Verification Command Comparison
The following table compares some useful show commands for verifying and troubleshooting an HSRP configuration.
Cisco NX-OS HSRP | Cisco IOS Software HSRP | Command Description |
show hsrp | show standby | Displays detailed information for all HSRP groups |
show hsrp active | - | Displays all of the groups in the “active” state |
show hsrp all | show standby all | Displays all of the groups including groups in the disabled state |
show hsrp bfd-sessions | - | Displays all BFD sessions |
show hsrp brief | show standby brief | Displays a summary of all the HSRP groups |
show hsrp delay | show standby delay | Displays minimum and maximum delay times for preempting |
show hsrp detail | - | Displays detailed information |
show hsrp group <#> | - | Displays detailed information for a specified group |
show hsrp init | - | Displays all the groups in the "init" state |
show hsrp interface | show standby int-type | Displays detailed information for a specific interface |
show hsrp learn | - | Displays all the groups in the "learn" state |
show hsrp listen | - | Displays all the groups in the "listen" state |
show hsrp speak | - | Displays all the groups in the "speak" state |
show hsrp standby | - | Displays all the groups in the "standby" state |
show hsrp summary | - | Displays summary information for HSRP groups |
- | - | - |
show track | show track | Displays the configured tracked objects |
show track brief | show track brief | Displays a brief list of tracked objects |
show track interface | show track interface | Displays the status of tracked interfaces |
show track ip | show track ip | Displays the IP protocol objects that are tracked |
Cisco NX-OS/IOS EIGRP Comparison
Objective
This tech note outlines the main differences in Enhanced Interior Gateway Protocol (EIGRP) support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.
EIGRP Overview
EIGRP is a Cisco proprietary hybrid distance vector routing protocol used to exchange network reachability information within an autonomous system.
Important Cisco NX-OS and Cisco IOS Software Differences
In Cisco NX-OS:
The EIGRP protocol supports In-Service-Software-Upgrades (ISSU) if two supervisors are present in a chassis (Graceful Restart must be enabled).
EIGRP command-line interface (CLI) configuration and verification commands are not available until you enable the EIGRP feature with the feature eigrp command.
The EIGRP protocol requires the Enterprise Services license.
Only the Internet Protocol (IP) is supported. Cisco IOS Software supports IP, IPX, and Appletalk.
The EIGRP instance can consist of 20 characters. Cisco IOS Software supports numbers 1- 65536.
Eight equal-cost paths are supported by default; Cisco NX-OS supports up to 16.
Route auto-summarization is disabled by default.
Networks and interfaces are added to an EIGRP instance under the interface configuration mode.
If a router ID is not manually configured, the loopback 0 IP address is always preferred. If loopback 0 does not exist, Cisco NX-OS selects the IP address for the first loopback interface in the configuration. If no loopback interfaces exist, Cisco NX-OS selects the IP address for the first physical interface in the configuration.
A default route can be generated with the default-information originate command, whereas Cisco IOS Software requires additional CLI commands to achieve similar results.
When interface authentication is configured, the EIGRP key is encrypted with Data Encryption Standard 3 (3DES) in the configuration. Cisco IOS Software requires the service password command.
Distribute-lists used to filter routes from routing updates are applied under the interface with the ip distribute-list eigrp command, as opposed to under the EIGRP router instance.
Maximum prefix thresholds (warning and withdraw) can be configured for redistributed routes using the redistribute maximum-prefix routing instance command. Cisco IOS Software does not have the ability to set maximum prefix thresholds for redistributed routes.
A route-map is always required when redistributing routes into an EIGRP instance. In Cisco IOS Software, a route-map is optional.
Things You Should Know
The following list provides some additional facts about Cisco NX-OS that should be helpful when designing, configuring, and maintaining an EIGRP network.
Four EIGRP instances can be configured per virtual device context (VDC).
Numerous Virtual Route Forwarding (VRF) instances can be associated with an EIGRP instance.
If the feature eigrp command is removed, all relevant EIGRP configuration information is also removed.
The shutdown command can be used to gracefully disable an EIGRP instance while retaining the configuration. This feature can also be applied per interface with the ip eigrp <instance> shutdown command.
An EIGRP instance can be restarted with the restart eigrp <instance> Exec command.
Graceful restart (RFC 3623) is enabled by default (It needs to be enabled in order to perform an ISSU upgrade).
Multiple EIGRP instances can be configured on the same interface.
Secondary IP addresses are advertised by default and cannot be suppressed per interface.
The show running-config eigrp command displays the current EIGRP configuration.
EIGRP supports Bidirectional Forwarding Detection (BFD), which can be configured to reduce network convergence time to less than one second.
Configuration Comparison
The following sample code shows configuration similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. There are three significant differences: Cisco NX-OS allows EIGRP to be enabled and disabled globally, and it has a more interface-centric configuration that makes it easier to read. In addition, Cisco NX-OS has the capability to generate a default route, whereas Cisco IOS Software requires additional CLI commands to achieve similar results.
Cisco IOS CLI | Cisco NX-OS CLI |
Enabling the EIGRP Feature |
Cisco IOS Software does not have the ability to enable or disable EIGRP. | feature eigrp |
Configuring an EIGRP Instance and Router ID |
router eigrp 10 eigrp router-id 192.168.1.1 | router eigrp 10 router-id 192.168.1.1 |
Associating a Network with an EIGRP Instance |
router eigrp 10 network 192.168.10.0 | interface Ethernet2/1 ip address 192.168.10.1/24 ip router eigrp 10 |
Configuring a Passive Interface |
router eigrp 10 network 192.168.10.0 passive-interface GigabitEthernet2/1 | interface Ethernet2/1 ip address 192.168.10.1/24 ip router eigrp 10 ip passive-interface eigrp 10 |
Configuring Interface Authentication (MD5) |
key chain eigrp-key key 1 key-string cisco123 interface GigabitEthernet2/1 ip address 192.168.10.1 255.255.255.0 ip authentication mode eigrp 10 md5 ip authentication key-chain eigrp 10 eigrp-key | key chain eigrp-key key 1 key-string 7 070c285f4d06485744 interface Ethernet2/1 ip address 192.168.10.1/24 ip router eigrp 10 ip authentication mode eigrp 10 md5 ip authentication key-chain eigrp 10 eigrp-key |
Configuring an EIGRP Distribution List to Filter Routes |
ip prefix-list eigrp-10-list seq 5 permit 159.142.1.0/24 router eigrp 10 network 192.168.10.0 distribute-list prefix eigrp-10-list out GigabitEthernet2/1 | ip prefix-list eigrp-10-list seq 5 permit 159.142.1.0/24 interface Ethernet2/1 ip address 192.168.10.1/24 ip router eigrp 10 ip distribute-list eigrp 10 prefix-list eigrp-10-list out |
Configuring Route Summarization |
interface GigabitEthernet2/1 ip address 192.168.10.1 255.255.255.0 ip summary-address eigrp 10 159.142.0.0 255.255.0.0 5 | interface Ethernet2/1 ip address 192.168.10.1/24 ip router eigrp 10 ip summary-address eigrp 10 159.142.0.0/16 |
Generating A Default Route (Conditional) |
Cisco IOS Software doesn’t have the same CLI to generate a default route, but redistribution or the ip summary address command can be used to achieve similar results. | router eigrp 10 default-information originate |
Configuring Route Redistribution (Permit all Static Routes) |
router eigrp 10 redistribute static | router eigrp 10 redistribute static route-map static-to-eigrp route-map static-to-eigrp permit 10 |
Configuring a VRF Instance for EIGRP Routing |
router eigrp 10 address-family ipv4 vrf customer-a autonomous-system 20 | router eigrp 10 vrf customer-a autonomous-system 20 |
Verification Command Comparison
The following table compares some useful show commands for verifying and troubleshooting an EIGRP network configuration.
Cisco NX-OS EIGRP | Cisco IOS Software EIGRP | Command Description |
show ip eigrp | - | Displays global EIGRP information for all instances |
show ip eigrp <instance> | show ip eigrp <#> | Displays global EIGRP information for a specific instance |
show ip eigrp accounting | show ip eigrp accounting | Displays the number of prefixes that each neighbor advertised |
show ip eigrp interfaces | show ip eigrp interfaces | Displays interfaces configured for EIGRP |
show ip eigrp interfaces detail | show ip eigrp interfaces detail | Displays detailed interface information |
show ip eigrp neighbors | show ip eigrp neighbors | Displays currently connected neighbors |
show ip eigrp neighbors detail | show ip eigrp neighbors detail | Displays connected neighbors and associated details |
show ip eigrp route | - | Displays EIGRP routes |
show ip eigrp route-map statistics redistribute <protocol> | - | Displays statistics for redistributed routes per protocol |
show ip eigrp topology | show ip eigrp topology | Displays the EIGRP topology table |
show ip eigrp traffic | show ip eigrp traffic | Displays statistics related to EIGRP |
show ip eigrp vrf | show ip eigrp vrf | Displays VRF information for a specified VRF instance |
Cisco NX-OS/IOS OSPF Comparison
Objective
This tech note outlines the main differences in Open Shortest Path First Version 2 (OSPFv2) support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.
OSPF Overview
OSPFv2 is an IETF (RFC 2328) standards-based dynamic link-state routing protocol used to exchange network reachability within an autonomous system.
Important Cisco NX-OS and Cisco IOS Software Differences
In Cisco NX-OS:
The OSPF feature supports stateful process restarts and In-Service-Software-Upgrades (ISSU) if two supervisors are present in a chassis.
OSPF command-line interface (CLI) configuration and verification commands are not available until you enable the OSPF feature with the feature ospf command.
The OSPF protocol requires the Enterprise Services license.
The OSPF instance can consists of 20 characters, whereas the IOS supports numbers 1 – 65536.
Eight equal-cost paths are supported by default. You can configure up to sixteen.
The default reference bandwidth used in the OSPF cost calculation is 40 Gbps.
Networks and interfaces are added to an OSPF instance under the interface configuration mode.
An OSPF area can be configured using decimal or decimal dotted notation, but it is always displayed in decimal dotted notation in the configuration and in the show command output.
Passive interfaces are applied to the interface as opposed to under the OSPF router instance.
If a router ID is not manually configured, the loopback 0 IP address is always preferred. If loopback 0 does not exist, Cisco NX-OS selects the IP address for the first loopback interface in the configuration. If no loopback interfaces exist, Cisco NX-OS selects the IP address for the first physical interface in the configuration.
Neighbor adjacency changes are not logged by default. The log-adjacency-changes CLI command is required under the OSPF instance.
When interface authentication is configured, the OSPF key is encrypted with Data Encryption Standard 3 (3DES) in the configuration. Cisco IOS Software requires the service password command.
The NX-OS does not support distribute-lists used to remove OSPF routes from the routing table. The NX-OS does support inter-area Type-3 LSA/route filtering using the filter-list command configured under the OSPF routing instance.
A route-map is always required when redistributing routes into an OSPF instance. In Cisco IOS Software, a route-map is optional.
Route redistribution advertises classless and classfull networks by default (no subnets option). Cisco IOS Software requires the subnets option to redistribute classless networks.
A VRF instance is configured under an OSPF instance (Numerous VRF instances can be associated to a single OSPF instance). In Cisco IOS Software, a VRF instance is associated to a single OSPF process in a one-to-one relationship.
Things You Should Know
The following list provides some additional facts about Cisco NX-OS that should be helpful when designing, configuring, and maintaining an OSPF network.
Four OSPF instances can be configured per virtual device context (VDC).
If you remove the feature ospf command, all relevant OSPF configuration information is also removed.
The shutdown command under the OSPF process can be used to disable OSPF while retaining the configuration. Similar functionality can also be applied per interface with the ip ospf shutdown command.
The show running-config ospf command displays the current OSPF configuration.
An OSPF instance can be restarted with the restart ospf <instance> Exec command.
You cannot configure multiple OSPF instances on the same interface.
An interface can support multi-area adjacencies using the multi-area option with the ip router ospf interface command.
Secondary IP addresses are advertised by default, but can be suppressed per interface with the ip router ospf <instance> area <#> secondaries none interface command.
By default all loopback IP address subnet masks are advertised in an LSA as a /32. The loopback interface command ip ospf advertise-subnet can be configured to advertise the primary IP address subnet mask. (This command does not apply to secondary IP addresses. They will still be advertised as a /32.)
OSPF supports Bidirectional Forwarding Detection (BFD), which can be configured to reduce network convergence time to less than 1 second.
When you rollover an OSPF authentication key in a combined Cisco NX-OS/Cisco IOS network, you should configure both keys on the Cisco NX-OS router to ensure that there is sufficient overlap between the old key and the new key for a smooth transition to the new key. You should configure the new key as a valid accept key on all the NX-OS and IOS routers before the new key becomes a valid generation key in the keychain. During the overlap period, Cisco NX-OS transmits the new OSPF key and accepts OSPF authenticated packets from both the old key and the new key.
Maximum prefix thresholds (warning and withdraw) can be configured for redistributed routes using the redistribute maximum-prefix routing instance command.
Configuration Comparison
The following sample code shows configuration similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. There are two significant differences: Cisco NX-OS allows OSPF to be enabled and disabled globally, and it has a more interface-centric configuration that makes it easier to read.
Cisco IOS CLI | Cisco NX-OS CLI |
Enabling the OSPF Feature |
Cisco IOS Software does not have the ability to enable or disable OSPF. | feature ospf |
Configuring an OSPF Instance and Router ID |
router ospf 10 router-id 192.168.1.1 | router ospf 10 router-id 192.168.1.1 |
Associating a Network with an OSPF Instance and Area |
router ospf 10 network 192.168.1.0 0.0.0.255 area 1 | interface Ethernet2/1 ip address 192.168.10.1/24 ip router ospf 10 area 1 |
Configuring a Passive Interface |
router ospf 10 passive-interface GigabitEthernet2/1 network 192.168.1.0 0.0.0.255 area 1 | interface Ethernet2/1 ip address 192.168.11.1/24 ip ospf passive-interface ip router ospf 10 area 0 |
Configuring Interface Authentication (MD5) |
interface GigabitEthernet2/1 ip address 192.168.10.1 255.255.255.0 ip ospf authentication message-digest ip ospf message-digest-key 1 md5 cisco123 | interface Ethernet2/1 ip address 192.168.10.1/24 ip ospf authentication message-digest ip ospf message-digest-key 1 md5 3 a667d47acc18ea6b ip router ospf 10 area 1 |
Configuring a Stub Area with the no summary Option |
router ospf 10 area 2 stub no-summary | router ospf 10 area 2 stub no-summary |
Creating a Not-So-Stubby Area (NSSA) and Generating a Default Route |
router ospf 10 area 3 nssa default-information-originate | router ospf 10 area 3 nssa default-information-originate |
Configuring Inter-Area and External Summarization |
router ospf 10 area 0 range 159.142.0.0 255.255.0.0 summary-address 172.16.0.0 255.255.0.0 | router ospf 10 area 0 range 159.142.0.0/16 summary-address 172.16.0.0/16 |
Generating a Default Route (Conditional) |
router ospf 10 default-information originate | router ospf 10 default-information originate |
Generating a Maximum Metric (Max-Metric) Value |
router ospf 10 max-metric router-lsa | router ospf 10 max-metric router-lsa |
Configuring Route Redistribution (Permit all Static Routes) |
router ospf 10 redistribute static subnets | router ospf 10 redistribute static route-map static-to-ospf route-map static-to-ospf permit 10 |
Configuring a VRF Instance for OSPF Routing |
router ospf 10 vrf customer-a | router ospf 10 vrf customer-a |
Verification Command Comparison
The following table compares some useful show commands for verifying and troubleshooting an OSPFv2 network configuration.
Cisco NX-OS OSPFv2 | Cisco IOS Software OSPFv2 | Command Description |
show ip ospf | show ip ospf | Displays information for all OSPF instances |
show ip ospf <instance> | show ip ospf <#> | Displays information for a specific OSPF instance |
show ip ospf border-routers | show ip ospf border-routers | Displays a list of border routers |
show ip ospf database | show ip ospf database | Displays OSPF database information |
show ip ospf interface | show ip ospf interface | Displays all OSPF enabled interfaces and associated status information |
show ip ospf interface brief | show ip ospf interface brief | Displays a brief list and status of OSPF enabled interfaces |
show ip ospf interface detail | - | Displays additional packet statistics for each interface |
show ip ospf lsa-content-changed-list | - | Displays the LSA's that changed content |
show ip ospf memory | - | Displays the memory allocated for OSPF |
show ip ospf neighbors | show ip ospf neighbor | Displays neighbor-specific information |
show ip ospf neighbors detail | show ip ospf neighbor detail | Displays details for each OSPF neighbor |
show ip ospf neighbors summary | - | Displays summary information and packet statistics for each OSPF neighbor |
show ip ospf policy statistics | - | Displays redistribution statistics for a specified protocol |
show ip ospf request-list | show ip ospf request-list | Displays a list of link-state advertisements (LSAs) that have been requested |
show ip ospf retransmission-list | show ip ospf retransmission-list | Displays a list of the link-state retransmission list |
show ip ospf route | - | Displays all routes learned through OSPF |
show ip ospf statistics | show ip ospf statistics | Displays OSPF LSA statistics |
show ip ospf summary-address | show ip ospf summary-address | Displays OSPF summarized networks |
show ip ospf traffic | show ip ospf traffic | Displays OSPF related packet counters |
show ip ospf virtual-links | show ip ospf virtual-links | Displays OSPF virtual links |
show ip ospf vrf | - | Displays information for a specified OSPF VRF instance |
Cisco NX-OS/IOS BGP (Basic) Comparison
Objective
This tech note outlines the main differences in Border Gateway Protocol support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for the Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.
BGP Overview
BGPv4 is a standard Exterior Routing Protocol defined in RFC 4271, commonly used to exchange network reachability information between autonomous systems. This document covers the features required for basic connectivity.
Important Cisco NX-OS and Cisco IOS Software Differences
In Cisco NX-OS:
BGP CLI configuration and verification commands are not available until you enable the BGP feature with the feature bgp command.
The BGP protocol requires an Enterprise Services license.
Autonomous system numbers can be configured as 16 or 32 bit values.
Address families need to be explicitly enabled (IE: IPv4 unicast, IPv6 unicast, etc…). All address families are disabled by default.
By default, eBGP supports 8 Equal Cost Paths and iBGP supports 1. The Cisco NX-OS supports up to 16 Equal Cost Paths for both eBGP and iBGP.
Automatic Route Summarization and Synchronization are disabled by default.
BGP consists of a hierarchical configuration based on neighbors and address families.
If a router ID is not manually configured, the loopback 0 IP address is always preferred. If loopback 0 does not exist, Cisco NX-OS selects the IP address for the first loopback interface in the configuration. If no loopback interfaces exist, Cisco NX-OS selects the IP address for the first physical interface in the configuration.
Neighbor logging is not enabled by default under the BGP instance. Neighbor logging can be enabled with the log-neighbor-changes command.
When neighbor authentication is configured, the BGP key is 3DES encrypted in the configuration. Cisco IOS Software requires the service password command to encrypt the password in the configuration.
Things You Should Know
The following list provides some additional facts about Cisco NX-OS that should be helpful when designing, configuring, and maintaining a BGP network.
One BGP instances can be configured per Virtual Device Context (VDC).
Numerous Virtual Route Forwarding (VRF) instances can be associated to a BGP instance.
If the feature bgp command is removed, all relevant BGP configuration information is also removed.
Network statements must be configured under their respective address-family configuration mode when advertising them via BGP.
The shutdown command under the BGP instance can be used to disable BGP while retaining the configuration.
The show running-config bgp command displays the current BGP configuration.
A BGP instance can be restarted with the restart bgp <instance #> command.
Configuration Comparison
The following sample configuration code similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. There are three significant differences: The Cisco NX-OS allows BGP to be enabled and disabled globally. It utilizes a hierarchical configuration that makes it easier to read. The Cisco NX-OS does not enable any address families by default. Each address-family needs to be explicitly enabled. The following examples demonstrate this using the IPv4 unicast address family.
Cisco IOS CLI | Cisco NX-OS CLI |
Enabling the BGP Feature |
Cisco IOS Software does not have the functionality to enable or disable BGP. | feature bgp |
Configuring a BGP Instance and Router ID |
router bgp 10 bgp router-id 192.168.1.1 | router bgp 10 router-id 192.168.1.1 |
Configuring a BGP Neighbor (Internal) |
router bgp 10 neighbor 192.168.2.1 remote-as 10 neighbor 192.168.2.1 update-source Loopback0 | router bgp 10 neighbor 192.168.2.1 remote-as 10 update-source loopback0 address-family ipv4 unicast |
Configuring a BGP Neighbor (External) |
router bgp 10 neighbor 192.168.10.2 remote-as 11 | router bgp 10 neighbor 192.168.10.2 remote-as 11 address-family ipv4 unicast |
Advertising a Network in an Address Family (IPv4) |
router bgp 10 network 159.142.1.0 mask 255.255.255.0 network 159.142.254.0 mask 255.255.255.0 neighbor 192.168.10.2 remote-as 11 | router bgp 10 address-family ipv4 unicast network 159.142.1.0/24 network 159.142.254.0/24 neighbor 192.168.10.2 remote-as 11 address-family ipv4 unicast |
Configuring Neighbor Authentication (MD5) |
router bgp 10 neighbor 192.168.10.2 remote-as 11 neighbor 192.168.10.2 password cisco123 | router bgp 10 neighbor 192.168.10.2 remote-as 11 password 3 a667d47acc18ea6b address-family ipv4 unicast |
Configuring an Aggregate Address (Summary-Only) |
router bgp 10 network 159.142.1.0 mask 255.255.255.0 network 159.142.254.0 mask 255.255.255.0 aggregate-address 159.142.0.0 255.255.0.0 summary-only neighbor 192.168.10.2 remote-as 11 | router bgp 10 address-family ipv4 unicast network 159.142.1.0/24 network 159.142.254.0/24 aggregate-address 159.142.0.0/16 summary-only neighbor 192.168.10.2 remote-as 11 address-family ipv4 unicast |
Generating a Default Route for a Neighbor |
router bgp 10 neighbor 192.168.10.2 remote-as 11 neighbor 192.168.10.2 default-originate | router bgp 10 neighbor 192.168.10.2 remote-as 11 address-family ipv4 unicast default-originate |
Verification Command Comparison
The following table compares some useful show commands for verifying and troubleshooting a BGP network configuration.
Cisco NX-OS BGP | Cisco IOS Software BGP | Command Description |
show bgp convergence | - | Displays global convergence information |
show bgp process | - | Displays global BGP process information |
show bgp sessions | - | Displays information for all neighbors |
show bgp statistics | - | Displays global BGP process statistics |
- | - | - |
show ip bgp <option> | show ip bgp | Displays BGP Process and BGP table entries |
show ip bgp x.x.x.x | show ip bgp x.x.x.x | Displays a specific network in the BGP table |
show ip bgp x.x.x.x vrf | - | Displays a network in a specified VRF BGP table |
show ip bgp x.x.x.x/len | show ip bgp x.x.x.x mask | Displays a specific prefix in the BGP table |
show ip bgp x.x.x.x/len longer-prefix | show ip bgp x.x.x.x mask longer-prefix | Displays a prefix in the table with longer prefixes |
show ip bgp all | show ip bgp all | Displays the BGP table for all protocol families |
show ip bgp community <word> | show ip bgp community <#> | Displays routes with a specific regular expression |
show ip bgp community <aa:nn> | - | Displays routes with a specific community value |
show ip bgp community internet | - | Displays BGP routes advertised to the Internet |
show ip bgp community no-advertise | show ip bgp community no-advertise | Displays BGP routes not advertised to peers |
show ip bgp community no-export | show ip bgp community no-export | Displays BGP routes not exported to next AS |
show ip bgp community no-export-spoofed | - | Displays BGP routes not sent to outside local AS |
show ip bgp community-list <name> | show ip bgp community-list <name> | Displays a specific BGP community list |
show ip bgp dampening dampened-paths | show ip bgp dampening dampened-paths | Displays all Dampened paths |
show ip bgp dampening flap-statistics | show ip bgp dampening flap-statistics | Displays flap statistics for BGP routes |
show ip bgp dampening history-paths | - | Displays all history paths |
show ip bgp dampening parameters | show ip bgp dampening parameters | Displays all of the Dampening parameters |
show ip bgp extcommunity <word> | - | Displays routes with a specific regular expression for extended communities |
show ip bgp extcommunity-list <name> | - | Displays a specific BGP extended community list |
show ip bgp filter-list | show ip bgp filter-list | Displays all routes matching a specified filter list |
show ip bgp flap-statistics | - | Displays all BGP route flap statistics |
show ip bgp ipv4 multicast <option> | show ip bgp ipv4 multicast <option> | Displays BGP IPv4 multicast address families |
show ip bgp ipv4 unicast <option> | show ip bgp ipv4 unicast <option> | Displays BGP IPv4 unicast address families |
show ip bgp neighbors | show ip bgp neighbors | Displays detailed neighbor information |
show ip bgp neighbors x.x.x.x | show ip bgp neighbors x.x.x.x | Displays detailed information for a neighbor |
show ip bgp nexthop x.x.x.x | - | Displays all routes matching a specified next-hop |
show ip bgp nexthop-database | - | Displays the next-hop database |
show ip bgp paths | show ip bgp paths | Displays all BGP paths |
show ip bgp peer-policy | - | Displays BGP peer policy by specified name |
show ip bgp peer-session | - | Displays information about a peer session |
show ip bgp peer-template | show ip bgp unicast ipv4 template | Displays information about a peer template |
show ip bgp prefix-list | show ip bgp prefix-list | Displays routes matching a specified prefix-list |
show ip bgp regexp | show ip bgp regexp | Displays routes matching a regular-expression |
show ip bgp received-paths | - | Displays the paths stored for soft reconfiguration |
show ip bgp route-map | show ip bgp route-map | Displays BGP routes matching a route-map |
show ip bgp summary | show ip bgp summary | Displays a summary list of neighbors and statistics |
show ip bgp vrf | show ip bgp vpnv4 vrf | Displays information for a specified BGP VRF |
Cisco NX-OS/IOS BGP (Advanced) Comparison
Objective
This tech note outlines the main differences in advanced Border Gateway Protocol (BGP) support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.
BGP Overview
BGPv4 is a standard exterior routing protocol defined in RFC 4271, commonly used to exchange network reachability information between autonomous systems. This document discusses route reflectors, confederations, peer templates, route-map policies and the prefix-list (route-filtering) feature.
Important Cisco NX-OS and Cisco IOS Software Differences
In Cisco NX-OS:
When configuring route reflectors, the route-reflector-client command is assigned per neighbor under the neighbor-specific address family.
When configuring confederations, the confederation is configured under the autonomous system without the leading bgp keyword.
Cisco NX-OS uses a peer template instead of a peer group to reuse common BGP policies.
Multiple policy templates can be applied to a single neighbor. Cisco IOS Software allows only one policy template per neighbor.
Cisco NX-OS does not require a manual reset for a neighbor when its routing policy is modified. Cisco IOS Software requires a hard or soft reset depending on the neighbor capabilities exchanged.
Things You Should Know
The following list provides some additional facts about Cisco NX-OS that should be helpful when designing, configuring, and maintaining an advanced BGP network configuration.
Peer and session templates define neighbor attributes such as security passwords, timers, and transport options.
Peer templates and session templates have identical configuration capabilities with one exception: peer templates can configure address families.
Peer and session templates are inherited by a neighbor through the BGP neighbor configuration mode.
Only one peer template and session template can be inherited by a single BGP neighbor.
Peer templates can inherit session templates.
Session templates can inherit other session templates.
Policy templates define address-family policies for inbound or outbound polices, including default-route origination, filter lists, route-map polices, prefix lists, etc.
Multiple policy templates can be assigned per neighbor. Policy templates are executed in order based on the configured sequence number.
Policy templates are inherited by a neighbor through the neighbor and address-family configuration mode.
Route-map polices can configure BGP attributes such as as-path, community lists, community attributes, dampening, local preference, metric type, origin, and weight.
Route-map polices can be applied per neighbor for inbound and outbound routing policies.
Configuration Comparison
The following sample code shows the configuration similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. The configurations are very similar with the exception of the hierarchy used in Cisco NX-OS.
Cisco IOS CLI | Cisco NX-OS CLI |
Configuring a Route-Reflector |
router bgp 10 no synchronization network 192.168.11.1 mask 255.255.255.255 neighbor 192.168.2.1 remote-as 10 neighbor 192.168.2.1 update-source Loopback0 neighbor 192.168.2.1 route-reflector-client no auto-summary | router bgp 10 address-family ipv4 unicast network 192.168.11.1/32 neighbor 192.168.2.1 remote-as 10 update-source loopback0 address-family ipv4 unicast route-reflector-client |
Configuring Confederations |
router bgp no synchronization bgp confederation identifier 10 bgp confederation peers 65535 network 192.168.11.1 mask 255.255.255.255 neighbor 192.168.10.2 remote-as 65535 no auto-summary | router bgp 65534 confederation identifier 10 confederation peers 65535 address-family ipv4 unicast network 192.168.11.1/32 neighbor 192.168.10.2 remote-as 65535 address-family ipv4 unicast |
Configuring a Peer Template |
router bgp 10 no synchronization network 192.168.11.1 mask 255.255.255.255 neighbor IBGP-Template peer-group neighbor IBGP-Template password cisco123 neighbor IBGP-Template update-source Loopback0 neighbor 192.168.2.1 remote-as 10 neighbor 192.168.2.1 peer-group IBGP-Template no auto-summary | router bgp 10 address-family ipv4 unicast network 192.168.11.1/32 template peer IBGP-Template password 3 a667d47acc18ea6b update-source loopback0 address-family ipv4 unicast neighbor 192.168.2.1 remote-as 10 inherit peer IBGP-Template |
Configuring a Policy Template |
router bgp 10 template peer-policy EBGP-Policy default-originate send-community exit-peer-policy no synchronization network 192.168.11.1 mask 255.255.255.255 neighbor 192.168.10.2 remote-as 20 neighbor 192.168.10.2 inherit peer-policy EBGP-Policy no auto-summary | router bgp 10 address-family ipv4 unicast network 192.168.11.1/32 template peer-policy EBGP-Policy send-community default-originate neighbor 192.168.10.2 remote-as 20 address-family ipv4 unicast inherit peer-policy EBGP-Policy 10 |
Configuring an Outbound Neighbor Route-Map Policy |
route-map EBGP-Policy permit 10 set as-path prepend 10 10 10 router bgp 10 no synchronization network 192.168.11.1 mask 255.255.255.255 neighbor 192.168.10.2 remote-as 20 neighbor 192.168.10.2 route-map EBGP-Policy out no auto-summary | route-map EBGP-Policy permit 10 set as-path prepend 10 10 10 router bgp 10 address-family ipv4 unicast network 192.168.11.1/32 neighbor 192.168.10.2 remote-as 20 address-family ipv4 unicast route-map EBGP-Policy out |
Configuring an Outbound Prefix-List |
ip prefix-list EBGP-Policy seq 5 permit 192.168.11.1/32 router bgp 10 no synchronization neighbor 192.168.10.2 remote-as 20 neighbor 192.168.10.2 prefix-list EBGP-Policy out no auto-summary | ip prefix-list EBGP-Policy seq 5 permit 192.168.11.1/32 router bgp 10 neighbor 192.168.10.2 remote-as 20 address-family ipv4 unicast prefix-list EBGP-Policy out |
Verification Command Comparison
The following table compares some useful show commands for verifying and troubleshooting a BGP network configuration.
Cisco NX-OS BGP | Cisco IOS Software BGP | Command Description |
show bgp convergence | - | Displays global convergence information |
show bgp process | - | Displays global BGP process information |
show bgp sessions | - | Displays information for all neighbors |
show bgp statistics | - | Displays global BGP process statistics |
- | - | - |
show ip bgp <option> | show ip bgp | Displays BGP Process and BGP table entries |
show ip bgp x.x.x.x | show ip bgp x.x.x.x | Displays a specific network in the BGP table |
show ip bgp x.x.x.x vrf | - | Displays a network in a specified VRF BGP table |
show ip bgp x.x.x.x/len | show ip bgp x.x.x.x mask | Displays a specific prefix in the BGP table |
show ip bgp x.x.x.x/len longer-prefix | show ip bgp x.x.x.x mask longer-prefix | Displays a prefix in the table with longer prefixes |
show ip bgp all | show ip bgp all | Displays the BGP table for all protocol families |
show ip bgp community <word> | show ip bgp community <#> | Displays routes with a specific regular expression |
show ip bgp community <aa:nn> | - | Displays routes with a specific community value |
show ip bgp community internet | - | Displays BGP routes advertised to the Internet |
show ip bgp community no-advertise | show ip bgp community no-advertise | Displays BGP routes not advertised to peers |
show ip bgp community no-export | show ip bgp community no-export | Displays BGP routes not exported to next AS |
show ip bgp community no-export-spoofed | - | Displays BGP routes not sent to outside local AS |
show ip bgp community-list <name> | show ip bgp community-list <name> | Displays a specific BGP community list |
show ip bgp dampening dampened-paths | show ip bgp dampening dampened-paths | Displays all Dampened paths |
show ip bgp dampening flap-statistics | show ip bgp dampening flap-statistics | Displays flap statistics for BGP routes |
show ip bgp dampening history-paths | - | Displays all history paths |
show ip bgp dampening parameters | show ip bgp dampening parameters | Displays all of the Dampening parameters |
show ip bgp extcommunity <word> | - | Displays routes with a specific regular expression for extended communities |
show ip bgp extcommunity-list <name> | - | Displays a specific BGP extended community list |
show ip bgp filter-list | show ip bgp filter-list | Displays all routes matching a specified filter list |
show ip bgp flap-statistics | - | Displays all BGP route flap statistics |
show ip bgp ipv4 multicast <option> | show ip bgp ipv4 multicast <option> | Displays BGP IPv4 multicast address families |
show ip bgp ipv4 unicast <option> | show ip bgp ipv4 unicast <option> | Displays BGP IPv4 unicast address families |
show ip bgp neighbors | show ip bgp neighbors | Displays detailed neighbor information |
show ip bgp neighbors x.x.x.x | show ip bgp neighbors x.x.x.x | Displays detailed information for a neighbor |
show ip bgp nexthop x.x.x.x | - | Displays all routes matching a specified next-hop |
show ip bgp nexthop-database | - | Displays the next-hop database |
show ip bgp paths | show ip bgp paths | Displays all BGP paths |
show ip bgp peer-policy | - | Displays BGP peer policy by specified name |
show ip bgp peer-session | - | Displays information about a peer session |
show ip bgp peer-template | show ip bgp unicast ipv4 template | Displays information about a peer template |
show ip bgp prefix-list | show ip bgp prefix-list | Displays routes matching a specified prefix-list |
show ip bgp regexp | show ip bgp regexp | Displays routes matching a regular-expression |
show ip bgp received-paths | - | Displays the paths stored for soft reconfiguration |
show ip bgp route-map | show ip bgp route-map | Displays BGP routes matching a route-map |
show ip bgp summary | show ip bgp summary | Displays a summary list of neighbors and statistics |
show ip bgp vrf | show ip bgp vpnv4 vrf | Displays information for a specified BGP VRF |
Nessun commento:
Posta un commento